DIY audio riešenia - Raspberry Pi (Hifiberry, IQaudIO....)

MP3/MP4 přehrávače, přehrávače videa, přenosné DVD přehrávače

Moderátor: Moderátoři AVMania.cz

Odeslat příspěvekod jbajci 26. 8. 2018 19:17

Dual mono mám v plánu. K napájení prozatím ifi ipower (samozřejmě uděláme hliníkovou krabičku jako na Bosse) Měl bych dotaz zda režim dual mono funguje v Moode. Jestli je třeba jej nějak složitě nastavovat, či se prostě vybere režim v menu moode. Pouštět to budu přes zesilovač Roksan Kandy K2 a repro B&W 684, což je takový lowend a sám si nejsem jist, zda bych , jak píše Pixxel, na takové sestavě slyšel rozdíl mezi Pianem a Katanou.
jbajci
Junior

Odeslat příspěvekod Pixxel 27. 8. 2018 06:58

Dual mono normálně zapneš v nastavení. Jen je třeba jeden ze cinčů napojit na ten poslední výstup pač dual mono znamená, že jeden kanál jde přes jeden chip a druhý kanál přes druhý čip.
Pixxel
Junior

Odeslat příspěvekod Pixxel 28. 8. 2018 07:21

A jestli ti můžu doporučit ještě jednu věc. Včera jsem zkusil dát za hlavu velký stropní akustický panel (1200x1200x50) co mám předpřipravený a na televizi deku a zvuk se razantně zlepšil k lepšímu. Je to takové klidnější a čistější celkově ten zvuk. Lepší lokalizace zvuků a prostoru. Určitě s úpravou akustiky místnosti budeš mít mnohem větší posun v kvalitě zvuku než kdybys piáno vyměnil za katanu;)
Pixxel
Junior

Odeslat příspěvekod jbajci 28. 8. 2018 11:21

Za hlavou mám velký plátěný obraz, není to akustický panel, ale lepší než nic. Deku přes televizi jsem zkusil taky a opravdu jsem pocítil zlepšení prostoru. Dnešní televize, to je poměrně velká odrazová plocha a ve většině obývacích pokojů jsou umístěny právě ve středu místnosti mezi reproduktory.
jbajci
Junior

Odeslat příspěvekod Pixxel 4. 9. 2018 07:28

Pomalu a jistě se už připravuje Moode 4.3, který bude mít už zaimplementovaný Spotify Connect. Hurá:). Já osobně jsem byl nucen přes víkend přejít na v4.2 čistou instalací protože mi starší moode začal z ničeho nic občas posílat šum a bordel do beden. Myslel jsem že je to starým zesíkem ale ten je v pohodě. Přeinstaloval jsem to a hraje to zase opět krásně:). Změny jsou podle mého jenom v GUI, je trochu svižnější. Osobně bych počkal na tu verzi 4.3 kdybych neměl ty problémy.
Pixxel
Junior

Odeslat příspěvekod _daRK 4. 9. 2018 09:11

Snad to bude uz aj realne funkcne bez tych lagov. Potom by to bola bomba a neviem sa dockat. Lebo ta implementacia Spotify Connect bola dlhodobo krepa a malo pouzitelna, do novych instalacii som to uz ani nedaval. Dokonca to bolo nebezpecne na usne bubienky, lebo to menilo hlasitost na maximum v appke ako sa jej zachcelo.
SONY KD-55XF9005; Yamaha RX-V683 ► DALI Zensor 3+Yamaha NS-SW200
Schiit Modi3+Magni3 ► Hifiman HE400i (ZMF Ori)
Fiio E10K 2 ► iBasso IT01; Shanling M0 ► iBasso IT01S, Dragonfly Black, Sony WH-1000XM2

PREDAJ: Whizzer Kylin (A-HE03),q-Jays II
_daRK
Pokročilý

Odeslat příspěvekod Pixxel 4. 9. 2018 12:38

Používám spotify connect z tohoto postupu a funguje to skvěle. Mám nastavenou hlasitost na 100% (--initial-volume 100) a nemám stím nejmenší problém. Hlasitost upravuju skrz relay attenuator desku ale hlasitost jde taky hezky ovládat i skrz spotify aplikaci v mobilu. Přepínání písniček skrz mobilaplikaci funguje parádně a žádné lagy jsem nazaznamenal.

cd /home/pi
sudo apt-get install build-essential portaudio19-dev git
git clone https://github.com/librespot-org/librespot.git
cd librespot/
curl https://sh.rustup.rs -sSf | sh
#from the given options choose 1
source $HOME/.cargo/env
sudo reboot

#Login again
cd /home/pi/librespot/
cargo build --release --features alsa-backend
#this will take a while, 30 minutes plus
# after this process is done, create a spotify-connect.service

sudo su
nano /etc/systemd/system/spotify-connect.service
#add the following to the spotify-connect.service file
#change --device depending on the device you are using
#change --name to your liking
#add if needed --username <your spotify username>
#add if needed --password <your spotify password>


[Unit]
Description=Spotify Connect
Requires=network-online.target
After=network-online.target

[Service]
User=root
ExecStart=/home/pi/librespot/target/release/librespot --name MoodeSpot --initial-volume 75 --cache /tmp --bitrate 320 --backend alsa --device hw:1
Restart=always
RestartSec=10
StartLimitInterval=30
StartLimitBurst=20

[Install]
WantedBy=multi-user.target

#save and close the file by 'ctrl x' -> 'y' -> enter
#start and enable the service
systemctl enable spotify-connect.service
systemctl start spotify-connect.service

#Make sure Moode is stopped before using Librespot and vise versa.

#to update
cd /home/pi/librespot
git pull
cargo build --release --features alsa-backend
sudo reboot
Pixxel
Junior

Odeslat příspěvekod martas38 4. 9. 2018 21:36

Ahoj! Měl bych dva dotazy. Provozuju doma dvě maliny. Jedna je jako multimediální centrum, má zvukovku Hifiberry DAC Pro a jede na ní Kodi pod OSMC. Pokud spustím film ozve se velice nepříjemné lupnutí. Je to patrně dáno přepnutím vzorkovací frekvence, protože když na tom pustím playlist hudby sestavený z Flaců s různou vzorkovací frekvencí, lupe to taky. Zajímalo by mě, jestli má někdo podobnou zkušenost a zda lze lupání zabránit? Zda je způsobeno Hifiberry, nebo Kodi?
Pak mám druhé zařízení na přehrávání hudby. Má kartu JustBoom DAC (podle mě zvukově lepší než Hifiberry a současně je levnější) a na ní jsem měl Moode Audio 4.1 pod Raspbianem, připojení přes wifi. To mám připojeno k bedýnkám Creative T20, tedy žádná kvalita. Sledoval jsem dva problémy. Jednak zařízení po chvíli nečinnosti usínalo tak, že bylo nedostupné přes webové rozhraní i SSH a dalo se vzbudit pouze pokud jsem na ně poslal hudbu přes airplay z mobilu či počítače - pak už bylo dostupné přes web i SSH. Dál se mně stávalo, že pokud jsem na malinu poslal hudbu z počítače, obvykle po pár skladbách přestala hrát, na počítači bylo nutno shodit a znovu pustit přehrávač. A tak stále dokola. Dal jsem pryč Moode a nahodil Volumio, kde se tohle neděje a vše funguje jak má. Děje se tohle někomu u Moode Audio též, případně dá se tomu nějak zabránit?
Ještě bych se chtěl zeptat. Obě maliny nevypínám, mám je puštěné nonstop. Hrozí zničení, nebo vyhořel někdo :-) ?
Díky za odpovědi!
Chord Mojo, Audio-gd NFB 12 -> Beyerdynamic DT880 Edition 2005, AKG K 142HD
HiBy R3, FiiO X3 2nd, Shanling M1 -> FiiO FH5, Dunu DN-2000J, LZ-A4, Trinity Delta
martas38
Mírně pokročilý

Odeslat příspěvekod _daRK 5. 9. 2018 07:33

Kodi pouzivam na filmy dlhodobo na troch malinach doma a ziaden podobny problem som nezaznamenal. Problem so zaspavanim systemu som riesil uz davno a myslim, ze to bolo bud na RuneAudio alebo Volumio. Tento svet raspberriek ma svoje caro, ze ? :)
Napadlo ma, ci to lupnutie nemoze byt uz na vstupe do repro alebo kde to mas vyvedene.
Ja maliny vypinam cez dialkovo vypinatelne zasuvky, ked som kupoval nedavno sluchatkac a nechal to bezat cez noc, zamrzlo to... dvakrat po sebe. Na druhej strane na forach to ludia bezne pisu, ze rpi nevypinaju. Podla mna, ak to nie je v zatazi, nic sa nestane, ved odber W to ma skoro zanedbatelny.
SONY KD-55XF9005; Yamaha RX-V683 ► DALI Zensor 3+Yamaha NS-SW200
Schiit Modi3+Magni3 ► Hifiman HE400i (ZMF Ori)
Fiio E10K 2 ► iBasso IT01; Shanling M0 ► iBasso IT01S, Dragonfly Black, Sony WH-1000XM2

PREDAJ: Whizzer Kylin (A-HE03),q-Jays II
_daRK
Pokročilý

Odeslat příspěvekod Pixxel 5. 9. 2018 09:12

No já nevím teda, mi moje audioMalina žere okolo 7-8W. Jinak problém s usínáním nemám pač to poctivě vypínám bo 8W už je celkem dost na nonstop chod. Jinak občas stopnu hudbu třeba na dvě tři hodiny a když ji chci zapnout tak ji vklidu zapnu bez problému. Neměl jsem stím problém. Přes noc jsem to nezkoušel.
Pixxel
Junior

Odeslat příspěvekod _daRK 5. 9. 2018 09:30

To ale meras v zatazi ? Lebo martas asi riesi bez zataze, a ak si dobre spominam, mne zrala fakt len zopar W, ked som ju nezatazil a este menej, ked som ju len softverovo vypol.
SONY KD-55XF9005; Yamaha RX-V683 ► DALI Zensor 3+Yamaha NS-SW200
Schiit Modi3+Magni3 ► Hifiman HE400i (ZMF Ori)
Fiio E10K 2 ► iBasso IT01; Shanling M0 ► iBasso IT01S, Dragonfly Black, Sony WH-1000XM2

PREDAJ: Whizzer Kylin (A-HE03),q-Jays II
_daRK
Pokročilý

Odeslat příspěvekod martas38 5. 9. 2018 18:32

daRK: A pod jakým systémem to Kodi provozuješ? Já napřed zkusil LibreELEC, ale tam mně procesor jel na tuším max 500MHz a systém byl víc než líný a nebyl jsem schopen to přinutit jet na 1,4GHz, několikrát jsem přeinstalovával atd. Pod OSMC to jede dobře až na to lupání. Začínám mít obavy, že je to vlastnost Hifiberry. Ještě mám v záloze OpenELEC.
Já nechávám obě krabičky zapnuté, nabootované, jen nic nepřehrávají. Mělo by se to po čase samo podtaktovat.
Jinak jsou to supermašinky. Já se s linuxem kámoším už přes deset let a o to je to pro mě zajímavější a zábavnější.
Chord Mojo, Audio-gd NFB 12 -> Beyerdynamic DT880 Edition 2005, AKG K 142HD
HiBy R3, FiiO X3 2nd, Shanling M1 -> FiiO FH5, Dunu DN-2000J, LZ-A4, Trinity Delta
martas38
Mírně pokročilý

Odeslat příspěvekod _daRK 5. 9. 2018 20:01

Libreelec+Kodi, predtym Openelec, ale neprisiel mi ani jeden pomaly, ale pozriem vecer, na kokych MHz to bezi.
Ja sa s Linuxom/unixom kamosim uz dobrych 25 rokov, len sme mali "trosku" pauzu :)
SONY KD-55XF9005; Yamaha RX-V683 ► DALI Zensor 3+Yamaha NS-SW200
Schiit Modi3+Magni3 ► Hifiman HE400i (ZMF Ori)
Fiio E10K 2 ► iBasso IT01; Shanling M0 ► iBasso IT01S, Dragonfly Black, Sony WH-1000XM2

PREDAJ: Whizzer Kylin (A-HE03),q-Jays II
_daRK
Pokročilý

Odeslat příspěvekod Pixxel 6. 9. 2018 07:40

To já linux a RPI začínám zase nenávidět:). Po víkendové reinstalaci a tří dnů super bezchybného fungování včera zase opět zničeho nic začala audioMalina pouštět do beden šíleně zkreslený silný zvuk že jsem se bál, že mi odpálila nové polky S60.
Po restartech a vypínání mi přestalo fungovat i dálkové ovládání přes LIRC(služba funguje ale irw příkaz nic nezachytí) a občas mi vypadnul i pravý kanál. Přestal fungovat dual-mono režim.
Zajímavé jak to začlo chrčet, tak jsem softwarově stopnul hudbu (přes mobil) a hned zapnul a vše bylo ok na chvíli. Podle mě je moode dementní neodladěný systém.
Všiml jsem si jedné věci. Na Kali reclockeru mi svítí modrá dioda, že se přehrává nějaký FLAC. Když začne zvuk blbnout tak KALI začne přeblikávat červeně a modře. Vypadá to, že RPI/Moode asi možná začne mít s něčím problém a začne tam posílat brajgl.
Nenappadá někoho kde by mohl být problém? KALI+Piano 2.1 + Relay Attenuator by měl být snad v pohodě. Napadá mě zkusit Volumio anebo zkusit zjistit jestli problém není od toho IR čidla.
Pixxel
Junior

Odeslat příspěvekod _daRK 6. 9. 2018 07:49

Vcera muselo byt nieco vo vzduchu, mne malina tiez strasne blbla, pozeral som film a stale sa sekala :( To sa nestalo ani nepamatam.... ak vobec.
Ale k veci... martas38, pozrel som si ten vykon v Kodi (libreelec) a aj mne ide len na polovicny vykon 600 MHz, nejako mi to okrem vcerajsieho sekania, neprislo spomalene pri videach na x264 . x265 samozrejme vzdy seka, ale to sa vie. Ten polovicny vykon na nete spominaju v suvislosti so zlym napajani, ale ja dam davam original RPi nabijacku, ale tiez pisu, ze on to sam prepne na 1,2GHz vzdy, ked to potrebuje. Asi preto som nikdy problem nezaznamenal.
SONY KD-55XF9005; Yamaha RX-V683 ► DALI Zensor 3+Yamaha NS-SW200
Schiit Modi3+Magni3 ► Hifiman HE400i (ZMF Ori)
Fiio E10K 2 ► iBasso IT01; Shanling M0 ► iBasso IT01S, Dragonfly Black, Sony WH-1000XM2

PREDAJ: Whizzer Kylin (A-HE03),q-Jays II
_daRK
Pokročilý

Předchozí stránkaDalší stránka

Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 0 návštevníků